MyTechSupport.ca :: Your Computer Technical Resource Headquarters! MyTechSupport.ca :: Your Computer Technical Resource Headquarters!
HOME FORUMS RESOURCES & TOOLS ARTICLES ONLINE STORE ABOUT US
Computer Support Forums arrow Software Support arrow Operating Systems : Microsoft arrow Topic: Boot.ini
October 22, 2019, 10:34:24 AM
 

Home Forum Rules Help Search Mobile Version Login Register

Welcome, Guest. Please login or register.
Did you miss your activation email?
October 22, 2019, 10:34:24 AM

Login with username, password and session length
 Featured Sites:
News
Welcome to MyTechSupport.ca! - Registration is FREE, so why not join our friendly community today?
  0 Members and 1 Guest are viewing this topic.
Pages: [1] 2 Go Down Print
Author Topic: Boot.ini  (Read 4307 times)
valpojim
Jr. Member
**

Karma: +0/-0
Offline Offline

Gender: Male
Posts: 14


Bookmark and Share

View Profile
« on: March 21, 2005, 06:59:34 PM »

PLEASE SUPPLY RELEVANT INFORMATION:
Operating System Version:
Problem Application Name & Version:
Problem Hardware Make & Model:
Error Messages:



Windows 98SE

I recently had imbitions to install WinXP on my getting older Dell computer. It will be five years old this Fall. A one gigahertz third generation PC. As I was getting along with the upgrade I decided not to go through with it and aborted the install. Here is my problem: When I boot my PC now it asks me which operating system do I want..XP or 98. The upgrade changed my boot.ini and now I want to get it back to just booting my Win98 operating system. How do I do that? Here is what my present boot.ini:

[Boot Loader]
Timeout=5
Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT
[Operating Systems]
C:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows XP Setup"
C:\="Microsoft Windows"

How should I edit it so it boots like I never tried to upgrade? Thanks.

Jim

Logged

 
redaxe
Supreme Loonie
Global Moderator
Hero Member
*****

Karma: +16/-0
Offline Offline

Gender: Male
Posts: 1276


Bookmark and Share

View Profile
« Reply #1 on: March 21, 2005, 10:45:29 PM »

Delete the following lines:

Timeout=5
Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT
C:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows XP Setup"

That should let you boot straight into Win98 without any hitches.
Logged

Ageless
Dark Overlord of the Universe
Global Moderator
Hero Member
*****

Karma: +4/-1
Offline Offline

Gender: Male
Posts: 1779



Bookmark and Share

View Profile
« Reply #2 on: March 21, 2005, 10:54:36 PM »

I'd also make sure that the directory C:\$Win_NT$.~BT is deleted completely. In it you'll find the installation files of Windows XP.

After you've done that, I am sure you can even delete the boot.ini file, as long as the bootsector of the C: drive is still in order. If you want to rebuild it to Windows 98 standards, make sure that boot.ini, ntldr and NTDetect.com are deleted, then boot with a windows 98 startup floppy and type at the A: prompt: fdisk /mbr

This will rebuild the master boot record to Win98 standard.
Also hoping you took the correct way of installing WinXP and didn't allow it to translate your file system to NTFS, or else you won't even be able to start up Win98.
« Last Edit: March 21, 2005, 10:58:51 PM by Ageless » Logged

Jord.
valpojim
Jr. Member
**

Karma: +0/-0
Offline Offline

Gender: Male
Posts: 14


Bookmark and Share

View Profile
« Reply #3 on: March 22, 2005, 12:45:27 AM »

Okay..I tried to change the boot.ini file and save it. This is what I got in reply:

This file exists with Read Only attributes. Please use a different file name.

Huh?

Logged

 
Ageless
Dark Overlord of the Universe
Global Moderator
Hero Member
*****

Karma: +4/-1
Offline Offline

Gender: Male
Posts: 1779



Bookmark and Share

View Profile
« Reply #4 on: March 22, 2005, 02:22:00 AM »

Yes, boot.ini is read-only, meaning it cannot be overwritten unless you take the read-only attribute off. Rightclick on boot.ini in Windows Explorer, properties, uncheck the read-only attribute. Change the things above, save the file, then add the read-only attribute again.
Logged

Jord.
valpojim
Jr. Member
**

Karma: +0/-0
Offline Offline

Gender: Male
Posts: 14


Bookmark and Share

View Profile
« Reply #5 on: March 26, 2005, 06:52:53 PM »

This morning I tried changing the boot.ini file as instructed. I had no problem editing the file once I removed the "read only" feature. After editing it I saved it I tried rebooting. It would not...telling me that I needed to reinstall a file....don't remember exactly what it was...hal something. It was the file needed to boot Win XP. So now I was shut out of my computer. I put the Win98 startup disk and booted into DOS. I tried editing the boot.ini file and...this is funny! It told me it was a read only file and I couldn't edit it. NO ****!! So I thought and then tried booting up in safe mode. That got me back in so I went to the boot.ini file and changed it back. Now I'm back where I started. Any new thoughts?
Logged

 
Cactus
Security & Virus Specialist
Global Moderator
Hero Member
*****

Karma: +2/-0
Offline Offline

Gender: Male
Posts: 4327


Bookmark and Share

View Profile
« Reply #6 on: March 26, 2005, 07:10:43 PM »

Try this valpojim ... Start by booting the system into Windows 98. Explore the folder that contains Windows XP, searching for all personal files or documents; move them to a safe place. Then just delete the entire folder that contains Windows XP. You may need to confirm that it's okay to delete read-only files, executable files, and so on.


Now select Run from the Start menu and enter MSCONFIG. Click on the tab entitled BOOT.INI, and click on the button that says Check All Boot Paths. Your system will report that the path used to launch Windows XP is not valid and offer to remove it. Click on Yes. From now on, your system should boot directly to Windows 98.


Cactus  
Logged

**PLEASE**.....do not post your hijack log in someone else's thread. Start a separate thread HERE! Thank you.

cactus@mytechsupport.ca

My System Specs

Avg Antivirus::Ad-Aware::Spybot::Windows Update::Recuva
Malwarebytes::SUPERAntiSpywareFREE
valpojim
Jr. Member
**

Karma: +0/-0
Offline Offline

Gender: Male
Posts: 14


Bookmark and Share

View Profile
« Reply #7 on: March 26, 2005, 10:01:56 PM »

Catus,
As far as I can see there is no folder named Windows XP. I stopped the installation very early on.
Jim
Logged

 
Cactus
Security & Virus Specialist
Global Moderator
Hero Member
*****

Karma: +2/-0
Offline Offline

Gender: Male
Posts: 4327


Bookmark and Share

View Profile
« Reply #8 on: March 26, 2005, 10:23:00 PM »

So DELETE the line in the INI file that refers to the XP OS...then Reboot

Cactus  
Logged

**PLEASE**.....do not post your hijack log in someone else's thread. Start a separate thread HERE! Thank you.

cactus@mytechsupport.ca

My System Specs

Avg Antivirus::Ad-Aware::Spybot::Windows Update::Recuva
Malwarebytes::SUPERAntiSpywareFREE
NoelMVP
Hero Member
*****

Karma: +1/-1
Offline Offline

Gender: Male
Posts: 221


Bookmark and Share

View Profile
« Reply #9 on: March 26, 2005, 10:56:06 PM »

Guys

Be careful about this - there is no easy way back if I'm wrong!!

What I think is needed here is to 'recondition' the drive into Win9x format - gracefully.

To do this, we need to use the SYS C: command from a floppy boot.

First, make sure that you have the correct boot disk/EBB/Startup disk for your OS (Win 98, or Win98SE?? - it does make a difference!)

Then boot using that floppy, and at the A:\> prompt, type

SYS C:

when the command prompt returns, take out the floppy, and reboot  - if we're lucky, then you should be back in Win98, and running smoothly.

HTH, and Good Luck
Logged

Noel Paton
(MS - MVP, Windows, 2002-2006)

Nil Carborundum Illegitemi
www.crashfixpc.com
Ageless
Dark Overlord of the Universe
Global Moderator
Hero Member
*****

Karma: +4/-1
Offline Offline

Gender: Male
Posts: 1779



Bookmark and Share

View Profile
« Reply #10 on: March 27, 2005, 06:04:23 AM »

Same what I told him in this thread, Noel. Smiley
Logged

Jord.
NoelMVP
Hero Member
*****

Karma: +1/-1
Offline Offline

Gender: Male
Posts: 221


Bookmark and Share

View Profile
« Reply #11 on: March 27, 2005, 06:44:28 AM »

That probably wouldnn't work in that instance since the formatting is probably wrong on the 'new' drive - it may be set to be a Primary Partition - but not to being an Active Partition. (which would need to be done prior to the SYS C: command issue)

Ib that case, using FDISK to set the partition to ACTIVE PRIMARY is required before using the SYS C: command - and I'm not sure that the data would survive such a switch (I might try it out sometime, though!) depending mostly on whether the partition was previously a Primay or an Extended Partition.

I'm not sure how he thinks he booted from the second drive - it's not possible unless he used the SYS C: command in the first place, and physically removed the first drive from the boot process - or used a boot manager (In which case, if he sets the drive to active prior to the swap, and then uses SYS C, he should be OK).
 His mention of a BOOT.INI file is interesting, since Win 98 contains no such file, and most boot managers, IIRC, don't use that filename to prevent confusion with the Win NT bootmanager file.


Logged

Noel Paton
(MS - MVP, Windows, 2002-2006)

Nil Carborundum Illegitemi
www.crashfixpc.com
Ageless
Dark Overlord of the Universe
Global Moderator
Hero Member
*****

Karma: +4/-1
Offline Offline

Gender: Male
Posts: 1779



Bookmark and Share

View Profile
« Reply #12 on: March 27, 2005, 06:54:05 AM »

Same problem I ran into, and a lack of (remembering) all the specifics of Win98.
Yet the problem I feel we're having here is how WinXP starts its setup. Doesn't it immediately at the start give you the option to make the partition/drive NTFS? Knowing my Windows 2000 setup, there's always the needful eye on having to choose to keep the partition as is, as FAT32.

If he missed that, his partition is already NTFS, he may only be able to start up his Win98SE with the bootup files of XP.

So Jim, please check for me what the status of your harddrive is. Go to Windows Explorer and rightclick on the C: drive, properties, then tell me what file system is being used. FAT32 or NTFS?
Logged

Jord.
valpojim
Jr. Member
**

Karma: +0/-0
Offline Offline

Gender: Male
Posts: 14


Bookmark and Share

View Profile
« Reply #13 on: March 27, 2005, 12:50:33 PM »

Silly as it may seem my lack of good judgement caused this problem. I wanted to be able to run another program that was only WinXP compatible. I have a copy of Windows XP home from my sister. It is not an upgrade version. I thought at the time that I would be led through menus during the install. If it wasn't going to work it would tell me. Well that didn't happen so I elected to cancell the install early on. To my surprise when I went to reboot the next day I got the error message that a file was missing and Windows was not able to boot. I restarted the computer and this time I saw that it was giving me an option. Boot to Win-XP or Win98. I chose Win98 and all was well again. Now each time I start up I have to wait and choose Win98 or the boot fails. This is when I decided to seek some advice from a Web Forum. I didn't think it would be this complicated to undo what had happened. I guessed wrong!
To shed some more light on what I have already stated...I bought and installed a second hard drive. I had it copy everything from my primary hard drive. I wanted to use this 2nd hard drive for a back-up incase the primary failed on me. Why? Because I have had two IBM hard drives crash on me since I bought this Dell. The first time I was able to save some of my files. The second time I didn't fair as well. Now I back-up many of my files to disk and no longer buy IBM drives. Since the 2nd drive contained all the files as the primary I thought I would swap the drives internally and all would be Okay. When I tried this, as I stated earlier, it would not boot. All I got was a flashing cursor. I decided for the time being to leave it alone. It is back in the old position or secondary drive (D: drive).
To answer the last question..I checked my C: drive and it is Fat32. I can live with I have and don't want to try something that will lock me out permanentaly. Unless someone knows for sure how to undo what I have done I'll keep things as they are. Thanks for all your suggestions and enjoy the Easter Holiday!
Jim
Logged

 
NoelMVP
Hero Member
*****

Karma: +1/-1
Offline Offline

Gender: Male
Posts: 221


Bookmark and Share

View Profile
« Reply #14 on: March 27, 2005, 01:33:56 PM »

Jee
Win 98 CANNOT run in NTFS - no matter how hard you try.
It seems from Jim's latest post that the formatting is still FAT32 - so my advice for a SYS C: should work, assuming there's anything left on the HD to work with.

Jim
Boot with a floppy - what does a DIR C:\ show??
if it shows the \WINDOWS folder, then you're in with a good achance of success, since XP's first action after installing the boot loader is to copy the required files across to the HD for quick access later.

Logged

Noel Paton
(MS - MVP, Windows, 2002-2006)

Nil Carborundum Illegitemi
www.crashfixpc.com
Pages: [1] 2 Go Up Print 
 
Jump to:  

Powered by MySQL Powered by PHP

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS!

Disclaimer
This site is NOT responsible for any damage that the information on this site may cause to your system. Everything you try, whether inspired by the response given from this site or not, is entirely at your own risk. All product names and company names used herein are for identification purpose only and may be trademarks or registered trademarks of their respective owners. We are in no way affiliated or representing any of the companies on this site unless specified.
Back to Top
Stop Spam Harvesters, Join Project Honey Pot Fight Back Against Spammers! Get Firefox! Get Thunderbird! View Sylvain Amyots profile on LinkedIn
Back to Top
Google visited last this page May 01, 2017, 04:40:12 AM